Start a new topic

Sustain during patch change

Hi folks


We've just started to make use of Forte with Kontakt 5 sounds for live work, as a replacement for a dying older keyboard we used to use. We're therefore getting used to the differences between keyboard patch switching and using Forte, and generally we're starting to get the output we want. However, there's one issue we've come across that's being a pain, and Googling and reading this forum hasn't produced an answer so far.


The issue is the gap you get when you patch switch. Using our old method, if you want to switch a sound, particularly when building up pad sounds, you hit the last chord with the previous pad loaded, hit the sustain pedal and patch switched. The old sound would continue happily until you released the sustain pedal and started to play the new patch. On the rig we have now, that's not happening - as soon as you hit the patch shift on Forte, the sound drops out completely whether or not the sustain pedal is down, and it sounds pretty pants as the whole momentum of the song dies. I've looked at MIDI settings etc but there doesn't seem to be anything obvious.


I'm fully prepared to accept that I'm doing something wrong, but it seems a reasonable requirement of a system. How do I sustain through a patch switch?


Thanks


Martin GK


1. Add Kontakt to the list of plugins that don't change with scene changes

2. Arrange sounds into Kontakt Banks

3. Use program change/bank change messages upon scene change to switch sounds


Check my answer here with links

http://www.brainspawn.com/forum/viewtopic.php?f=19&t=4830&p=24767#p24767




 Hi Antal - thank you for that. I'll try it out this evening or tomorrow. Thanks for the assistance!

OK - we're halfway there. I have the bank set up with some random sounds for now to prove the issue, I have two scenes in Forte which now send program changes correctly to select the right instrument from the bank for that scene, and I can switch between them happily. And, if I select one scene, play a chord and hit the sustain pedal,. then switch scene, the sound is still going on - great, it works!

Except that it now never stops and never dies - whatever I play using the second scene, I'm still hearing the sustained chord from scene 1 for ever as well - it doesn't release when you lift the sustain pedal back off. The only way I can get rid of it is by switching back to scene 1 again.

Is there a setting I have missed somewhere?

Thanks

 

The other problem is that this method seems to be very limiting - it reduces you to single sounds, as you can't load a Kontakt bank with a multi sound. As I understand it, this method therefore only works if you don't want to use multis and switch between them - which seems to restrict it to only a small amount of the sound that can be produuced. Is there really no way to switch between two multis and keep the previous one sustaining while you switch? It seems a fairly basic performance requirement.

Thanks for any ideas!

 

Great! You're nearly there. Regarding 1: that's indeed strange. I've been using this method for a long time and never had these issues. Did you exclude Kontakt from receiving blobs in the general settings? Could you post a screenshot of your plugin settings? Regarding 2: Not at all. That's how i use it as well. Just set up four separate Kontakt banks each on a different midi channel. Then send patch/back changes to each on scene change and set up the MIDI routing so that your controller sends MIDI to those four channels internally (layer). For convenience, you can load a multi using the option not to clear the current multi and then just drag the individual patches into empty slots in the separate banks. Slightly confusing wording maybe, but does that make sense?

 Hi Antal - thanks again for the reply. I can see using the diagnostics that Forte is definitely getting the pedal off as well as the pedal on MIDI message, but it doesn't seem to stop the previous scene from continuing to sound. I can find anything in the settings of either Forte or Kontakt that mentions blobs at all. I currently have "All notes off" switched on, and "All sounds off" and "Reset all controllers" switched off in the scene commands section for each scene, if that helps.


I'm a bit stuck on your other idea  as well - the big piano I am using as my master keyboard can only transmit on a single channel,  so unless there's some clever routing that can be done somewhere I'm stuck with a single MIDI channel, which I think eliminates your possible alternative for getting some multiple sounds working.


Thanks

Ad 1: Check that Kontakt 5 is included in this list as seen here...
http://www.brainspawn.com/documents/forte4help/scene_options.htm

Ad 2: You do the layering of MIDI channels within forte itself. Where the MIDI incoming from your controller on channel 1 (let's say) is duplicated to multiple channels internally before it reaches the plugin. See here...
http://www.brainspawn.com/documents/forte4help/midi_filtering_and_automation.htm

 

Ad 2 - that's working perfectly, and immediately - thank you very much. I can see how that works now.

Ad 1 - I definitely have Kontakt in that list, although I think my version (4.2.7) is slightly newer as the screen shot of the options looks slightly different, but I can see the list you mean. Its infuriating - I can see the midi pedal off event arriving, it just seems only to apply to the scene you have loaded at the time. Thanks for all the help so far - is there anything else you can suggest?

 

2: ok cool
1: very strange.I can try some things out, but I'm using 5.6.8 here and I'm not sure how that translates

 

Sorry - I didn't make that clear. I'm on Forte 4.2.7 - My Kontakt is 5.6.6.

 

Ah, ok. Should be the same then....
I'll try and have a look with my own rig.

What controller are you using?

 

Login or Signup to post a comment